Cara Mengganti Nama ISP pada Speedtest

Pernahkah pembaca pensaran bagaimana cara mengganti nama ISP pada speedtest? Biasanya ini sering di tanyakan di forum-forum RTRWNET. Tujuannya agar supply internet jaringannya utamanya (ISP) tidak diketahui jika menggunakan aplikasi speedtest. Teknik yang saya bagikan ini baru diterapkan pada jaringan dengan router MikroTik.

Sebelum melakukan teknik ini, ada syarat yang harus anda penuhi, yaitu anda harus memiliki akun VPN. Akun VPN ini bertujuan untuk membelokkan traffic-traffic jaringan yang menuju ke server speedtest agar dianggap berasal dari server VPN. Jadi sebenarnya, nama ISP akan diganti dengan nama jaringan yang ada pada server VPN. Sebagai contoh LOGAM.ID menggunakan server VPN yang berada pada jaringan Exabytes, sehingga nama ISP berubah menjadi PT. Exabytes Network.

Wah, mahal dong harus sewa server VPN. Tenang, LOGAM.ID memiliki layanan VPN Remote dengan harga mulai dari Rp 12.500/bulan (jika berlangganan tahunan). VPN Remote ini berguna bagi pembaca yang ingin bisa me-remote router MikroTik-nya di mana saja dan kapan saja. Atau bisa juga berlangganan Cloud Userman, karena dengan berlangganan
Cloud Userman gratis layanan VPN Remote juga. Info selanjutnya bisa lihat layanan VPN Remote dan Cloud Userman atau kontak kami ya. 😉

Nah kalau sudah punya akun VPN, pembaca bisa menjalankan script di bawah ini.

:log warning ""
:log warning "################################"
:log warning "Masking Sepedtest Job - START"
:log warning "################################"
:log warning ""

:local interfaceName ("nama-vpn")

:log warning ""
:log warning "Adding private address list"
/ip firewall address-list add list="private-lokal" address=0.0.0.0/8
/ip firewall address-list add list="private-lokal" address=10.0.0.0/8
/ip firewall address-list add list="private-lokal" address=100.64.0.0/10
/ip firewall address-list add list="private-lokal" address=127.0.0.0/8
/ip firewall address-list add list="private-lokal" address=169.254.0.0/16
/ip firewall address-list add list="private-lokal" address=172.16.0.0/12
/ip firewall address-list add list="private-lokal" address=192.0.0.0/24
/ip firewall address-list add list="private-lokal" address=192.0.2.0/24
/ip firewall address-list add list="private-lokal" address=192.168.0.0/16
/ip firewall address-list add list="private-lokal" address=198.18.0.0/15
/ip firewall address-list add list="private-lokal" address=198.51.100.0/24
/ip firewall address-list add list="private-lokal" address=203.0.113.0/24
/ip firewall address-list add list="private-lokal" address=224.0.0.0/3
:log warning "Private address list added"
:log warning ""

:log warning "Adding speedtest address list"
/ip firewall address-list add address=yougetsignal.com list=speedtest
/ip firewall address-list add address=xmyip.com list=speedtest
/ip firewall address-list add address=www.yougetsignal.com list=speedtest
/ip firewall address-list add address=expressvpn.com list=speedtest
/ip firewall address-list add address=www.expressvpn.com list=speedtest
/ip firewall address-list add address=whatismyip.net list=speedtest
/ip firewall address-list add address=speedtestcustom.com comment=whatismyip.net list=speedtest
/ip firewall address-list add address=income.speedtestcustom.com comment=speedtestcustom.com list=speedtest
/ip firewall address-list add address=iplocation.net comment=income.speedtestcustom.com list=speedtest
/ip firewall address-list add address=www.iplocation.net comment=iplocation.net list=speedtest
/ip firewall address-list add address=www.astrill.com comment=www.iplocation.net list=speedtest
/ip firewall address-list add address=www.privateinternetaccess.com comment=www.astrill.com list=speedtest
/ip firewall address-list add address=mxtoolbox.com comment=www.privateinternetaccess.com list=speedtest
/ip firewall address-list add address=ifconfig.co comment=mxtoolbox.com list=speedtest
/ip firewall address-list add address=whatismyip.org comment=ifconfig.co list=speedtest
/ip firewall address-list add address=www.goldenfrog.com comment=whatismyip.org list=speedtest
/ip firewall address-list add address=www.mxtoolbox.com comment=www.goldenfrog.com list=speedtest
/ip firewall address-list add address=www.ultratools.com comment=www.mxtoolbox.com list=speedtest
/ip firewall address-list add address=www.ip-adress.eu comment=www.ultratools.com list=speedtest
/ip firewall address-list add address=iplogger.org list=speedtest
/ip firewall address-list add address=www.vermiip.es list=speedtest
/ip firewall address-list add address=www.purevpn.com list=speedtest
/ip firewall address-list add address=www.whatismybrowser.com list=speedtest
/ip firewall address-list add address=zenmate.com list=speedtest
/ip firewall address-list add address=www.ipchicken.com list=speedtest
/ip firewall address-list add address=bittrex.com list=speedtest
/ip firewall address-list add address=whatismyip.li list=speedtest
/ip firewall address-list add address=www.ipburger.com list=speedtest
/ip firewall address-list add address=cbn.net.id list=speedtest
/ip firewall address-list add address=whatismyip4.com list=speedtest
/ip firewall address-list add address=www.inmotionhosting.com list=speedtest
/ip firewall address-list add address=nordvpn.com list=speedtest
/ip firewall address-list add address=wolframalpha.com list=speedtest
/ip firewall address-list add address=cactusvpn.com list=speedtest
/ip firewall address-list add address=www.cactusvpn.com list=speedtest
/ip firewall address-list add address=m.wolframalpha.com list=speedtest
/ip firewall address-list add address=ipcow.com list=speedtest
/ip firewall address-list add address=whatismycountry.com list=speedtest
/ip firewall address-list add address=passwordsgenerator.net list=speedtest
/ip firewall address-list add address=att-services.net list=speedtest
/ip firewall address-list add address=wtfismyip.com list=speedtest
/ip firewall address-list add address=whatismyip.network list=speedtest
/ip firewall address-list add address=ipinfo.info list=speedtest
/ip firewall address-list add address=encodable.com list=speedtest
/ip firewall address-list add address=www.overplay.net list=speedtest
/ip firewall address-list add address=myipaddress.com list=speedtest
/ip firewall address-list add address=www.myipaddress.com list=speedtest
/ip firewall address-list add address=whoer.net list=speedtest
/ip firewall address-list add address=whatismyip.com list=speedtest
/ip firewall address-list add address=www.speedtest.net list=speedtest
/ip firewall address-list add address=c.speedtest.net list=speedtest
/ip firewall address-list add address=www.ipleak.net list=speedtest
/ip firewall address-list add address=ipleak.net list=speedtest
/ip firewall address-list add address=whatismyipaddress.com list=speedtest
/ip firewall address-list add address=whatismyip.host list=speedtest
/ip firewall address-list add address=bearsmyip.com list=speedtest
/ip firewall address-list add address=check-host.net list=speedtest
/ip firewall address-list add address=hide.me list=speedtest
/ip firewall address-list add address=ipv6test.hide.me list=speedtest
/ip firewall address-list add address=ipleak.com list=speedtest
/ip firewall address-list add address=www.perfect-privacy.com list=speedtest
/ip firewall address-list add address=perfect-privacy.com list=speedtest
/ip firewall address-list add address=www.whatsmyip.org list=speedtest
/ip firewall address-list add address=whatsmyip.org list=speedtest
:log warning "Speedtest address list added"
:log warning ""

:log warning "Adding speedtest route"
/ip route add check-gateway=ping comment="<<<===|| VPN-SPEEDTEST ||===>>>" distance=1 gateway=$interfaceName routing-mark=VPN
:log warning "Speedtest route added"
:log warning ""

:log warning "Adding speedtest NAT"
/ip firewall nat add action=masquerade chain=srcnat comment="<<<===|| VPN-SPEEDTEST ||===>>>" out-interface=$interfaceName
:log warning "Speedtest NAT added"
:log warning ""

:log warning "Adding speedtest mangle"
/ip firewall mangle add action=mark-routing chain=prerouting comment="<<<===|| VPN-SPEEDTEST ||===>>>" dst-address-list=speedtest new-routing-mark=VPN passthrough=no src-address-list=private-lokal
:log warning "Speedtest mangle added"

:log warning ""
:log warning "################################"
:log warning "Masking Sepedtest Job - END"
:log warning "################################"
:log warning ""
Catatan
Sebelum dijalankan, ganti terlebih dahulu parameter:
:local interfaceName (“nama-vpn”)
“nama-vpn” diganti dengan nama interface VPN yang pembaca gunakan ya.

Kemudian silahkan dicopy seluruh text script tersebut. Kemudian buka Winbox, masuk ke System > Scripts. Klik tombol ( + ), lalu paste script pada bagian source. Klik Apply lalu klik Run. Cek di log, apakah script sudah jalan dengan sempurna. Jika sudah dijalankan dengan sempurna, silahkan dicoba speedtest menggunakan aplikasi speedtest atau dengan browser. Seharusnya nama ISP sudah diganti dengan nama server VPN.

Oke begitu saja tips dari LOGAM.ID bagaimana cara mengganti nama ISP pada Speedtest. Semoga bermanfaat ya. 😉

__________
Referensi tutorial ini berasal dari artikel:
https://www.ramitan.com/tutorial/mikrotik/mengubah-ip-publik-dan-nama-isp-jaringan-mikrotik-pada-speedtest/

Leave a Comment

Your email address will not be published. Required fields are marked *

MIKHMON ONLINEMIKBOTAM ONLINE MIKMOS ONLINE dan MikroTik API lainnya  KLIK DI SINI

Open chat
1
Hi, ada yang bisa kami bantu?
Powered by