[ SCRIPT ] Cara Menghemat IP Pool pada Jaringan Hotspot Mikrotik

IP Pool merupakan rentang alamat IP yang digunakan oleh DHCP untuk diberikan ke pada perangkat. Misal, jaringan anda menggunakan alamat IP 192.168.1.0/24, maka pada dasarnya rentang alamat IP yang dapat digunakan adalah dari 192.168.1.1 sampai 192.168.1.254. Rentang IP 192.168.1.1 – 192.168.1.254 dapat dijadikan sebuah IP Pool, sehingga IP pool tersebut menyediakan sebanyak 254 alamat IP yang dapat digunakan oleh DHCP. Namun jumlah alamat IP pada IP pool juga dapat diatur sesuai kebutuhan. Sebagai contoh anda hanya ingin menggunakan 200 alamat IP dari 254 yang tersedia untuk keperluan DHCP dan sisanya (sebanyak 54 alamat IP) anda dapat menggunakan IP statis karena kondisi tertentu.

Pada MikroTik, IP Pool ini berada pada IP → Pool. Pool ini dapat digunakan untuk berbagai kebutuhan, salah satunya adalah pemberian alamat secara otomatis oleh DHCP pada jaringan hotspot. Setiap perangkat yang terhubung ke jaringan hotspot, akan langsung diberikan alamat IP oleh DHCP (walaupun perangkat belum login). Jika jaringan hotspot anda berada di daerah yang sedikit pengguna, mungkin tidak terlalu bermasalah jika anda hanya menggunakan subnet /24. Namun /24 akan bermasalah ketika jaringan hotspot anda berada di tempat yang ramai seperti tempat berkumpulnya orang atau tempat lalu lalang. Terkadang, subnet /24 tidak cukup karena banyaknya perangkat yang terhubung sehingga IP pada IP Pool habis. Salah solusi untuk mengatasi ini, anda bisa menggunakan subnet /22 yang menyediakan 1024 alamat IP. Namun, masalah kehabisan IP tetap bisa terjadi (karena kondisi). Contohnya beberapa waktu lalu salah satu klien LOGAM.ID mengeluhkan ada perangkat yang tidak dapat terhubung dengan jaringan hotspotnya. Setelah ditelusuri, ternyata IP pool sudah penuh digunakan, walaupun sudah menggunakan subnet /22.

Permasalahan ini membuat LOGAM.ID mencari solusi yang terbaik dalam mengatur IP pool. Ide sederhananya adalah, IP address yang ada pada IP pool sebenarnya hanya digunakan oleh perangkat hotspot yang aktif (sudah login). Karena itu, semua IP yang tidak login harus dihapus dari DHCP lease agar IP pool bersih dari perangkat yang tidak aktif atau tidak login. Berikut cara yang dapat anda gunakan untuk bersih-bersih DHCP lease agar IP pool anda hemat.

Buat sebuah scheduler (System → Scheduler) dengan interval sesuai yang diinginkan (sebagai contoh, script ini dijalankan setiap 6 jam sekali), lalu copy & paste script di bawah ini pada bagian source.

# Make Static Lease for Active Hotspot
:log warning message=("[START] * CLEAN UP DYNAMIC DHCP LEASE *");
:foreach z in=[/ip hotspot active find] do={
:local u ([/ip hotspot active get $z user]);
:local m ([/ip hotspot active get $z mac-address]);
:local a ([/ip hotspot active get $z address]);
/ip dhcp-server lease make-static [/ip dhcp-server lease find mac-address=$m];
/ip dhcp-server lease comment [find mac-address=$m] $u;
};

# Clean Dynamic Lease and Waiting Status
/ip dhcp-server lease remove [find dynamic]
/ip dhcp lease remove [find where status=waiting]
:log warning message=("[END] * CLEAN UP DYNAMIC DHCP LEASE *");

Setelah anda paste kode tersebut pada bagian source. Klik Apply → OK. Dengan demikian script ini akan melakukan bersih-bersih secara berkala sesuai dengan interval yang telah ditentukan. Semoga bermanfaat.

Leave a Comment

Your email address will not be published. Required fields are marked *

MIKHMON ONLINEMIKBOTAM ONLINE MIKMOS ONLINE dan MikroTik API lainnya  KLIK DI SINI

Open chat
1
Hi, ada yang bisa kami bantu?